Wednesday, December 2, 2015

Uri problem 1040 solve

Problem :

Average 3

Adapted by Neilor Tonin, URI  Brazil
Timelimit: 1
Read four numbers (N1, N2, N3, N4), which one with 1 digit after the decimal point, corresponding to 4 scores obtained by a student. Calculate the average with weights 2, 3, 4 e 1 respectively, for these 4 scores and print the message "Media: " (Average), followed by the calculated result. If the average was 7.0 or more, print the message "Aluno aprovado." (Approved Student). If the average was less than 5.0, print the message: "Aluno reprovado." (Reproved Student). If the average was between 5.0 and 6.9, including these, the program must print the message "Aluno em exame." (In exam student).
In case of exam, read one more score. Print the message "Nota do exame: " (Exam score) followed by the typed score. Recalculate the average (sum the exam score with the previos calculated average and divide by 2) and print the message “Aluno aprovado.” (Approved student) in case of average 5.0 or more) or"Aluno reprovado." (Reproved student) in case of average 4.9 or less. For these 2 cases (approved or reproved after the exam) print the message "Media final: " (Final average) follow by the final average for this student in the last line.

Input

The input contains four floating point numbers that represent the students' note. Case necessary there will be one more floating point number, representing the 5th note.

Output

Print all the answers with one digit after the decimal point.
Sample InputSample Output
2.0 4.0 7.5 8.0
6.4
Media: 5.4
Aluno em exame.
Nota do exame: 6.4
Aluno aprovado.
Media final: 5.9
2.0 6.5 4.0 9.0Media: 4.8
Aluno reprovado.
9.0 4.0 8.5 9.0Media: 7.3
Aluno aprovado.

Solution:


#include <stdio.h>
  
int main() {
  
   float N1 ,N2 , N3 , N4 ,Media , extra ,final ;
    scanf("%f %f %f %f",&N1,&N2,&N3,&N4);
    Media=((N1*2)+(N2*3)+(N3*4)+(N4*1))/10;
    printf("Media: %.1f\n",Media);
    if (Media>7.0)
    {
        printf("Aluno aprovado.\n");
    }
    else if(Media<5.0)
    {
        printf("Aluno reprovado.\n");
    }
    else if(Media<6.9 && Media >= 5.0)
    {
        printf("Aluno em exame.\n");
        scanf("%f",&extra);
        printf("Nota do exame: %.1f\n",extra);
        final=(Media+extra)/2;
        if(final >= 5.0)
        {
            printf("Aluno aprovado.\n");
        }
        else if (final<=4.9)
        {
            printf("Aluno reprovado.\n");
        }
        printf("Media final: %.1f\n",final);
    }
  
    return 0;
}

No comments:

Post a Comment