Wednesday, December 2, 2015

Uri problem 1035 solve

Problem :

Selection Test 1

Adapted by Neilor Tonin, URI  Brazil
Timelimit: 1
Read 4 integer numbers A, B, C and D. Then if B is greater than C and D is greater than A and if the sum of C and D is greater than the sum of A and B and if C and D were positives values and if A is even, write the message “Valores aceitos” (Accepted values). Otherwise, write the message “Valores nao aceitos”(Values not accepted).

Input

Four integer numbers A, B, C and D.

Output

Show the corresponding message after the validation of the values​​.
Sample InputSample Output
5 6 7 8Valores nao aceitos
2 3 2 6Valores aceitos

Solution:

#include <stdio.h>
  
int main() {
  
     int A , B ,C , D ;
    scanf("%d %d %d %d",&A,&B,&C,&D);
    if(B>C && D>A && (A+B) < (C+D) && A%2 == 0 && (D>0) && (C>0))
        {
        printf("Valores aceitos\n");
    }
    else{
        printf("Valores nao aceitos\n");
    }
  
    return 0;
}

No comments:

Post a Comment