Wednesday, December 2, 2015

Uri problem 1008 solve

Problem :

Salary

Adapted by Neilor Tonin, URI  Brazil
Timelimit: 1
Write a program that reads the number of an employee, the number of hours that he worked in a month and the amount he received per hour. Print the employee number and the salary that he will receive at end of the month, rounded to two decimal places.
  • Don’t forget to print end line after the result otherwise you will get “Presentation Error”.
  • Don’t forget the space before and after the equal signal and after the U$.

Input

The input file contains 2 integer numbers and 1 floating-point number, respectively the number, hours worked and the among received by an hour worked.

Output

Print the number and the salary of the employee, according to the given example, with a blank space before and after the equal signal.
Sample InputSample Output
25
100
5.50
NUMBER = 25
SALARY = U$ 550.00
1
200
20.50
NUMBER = 1
SALARY = U$ 4100.00
6
145
15.55
NUMBER = 6
SALARY = U$ 2254.75

Solution:


#include <stdio.h>
  
int main() {
  
int NUMBER , hour;
    float value, SALARY;
    scanf("%d %d %f",&NUMBER , &hour,&value);
    SALARY = hour*value;
    printf("NUMBER = %d\n",NUMBER);
    printf("SALARY = U$ %.2f\n",SALARY);
  
    return 0;
}

No comments:

Post a Comment