Problem :
Fuel Spent
Adapted by Neilor Tonin, URI Brazil
Timelimit: 1
Little John wants to calculate and show the amount of liters of fuel spent on a trip, using a car that does 12 Km/L. For this, he would like you to help him through a simple program. To perform the calculation, you have to read time spent (in hours) and the same average speed (km/h). This way you can get distance and then calculate how many liters would be needed. Print the result rounded to three decimal places.
Input
The input file contains two integers. The first one is the time spent in the trip (in hours). The second one is the average velocity during the trip (in Km/h).
Output
Print how many liters would be needed to do this trip, with three digits after the decimal point.
Sample Input | Sample Output |
10 85 | 70.833 |
2 92 | 15.333 |
22 67 | 122.833 |
Solution:
#include <stdio.h>
int
main() {
int
time
, velocity ;
float
fuel , distance;
scanf
(
"%d %d"
,&
time
,&velocity);
distance =
time
*velocity;
fuel= distance/12 ;
printf
(
"%.3f\n"
,fuel);
return
0;
}
No comments:
Post a Comment