Problem :
Area
Adapted by Neilor Tonin, URI
Brazil
Timelimit: 1
Make a program that reads three floating-point values: A, B and C. Then calculate and print:
a) the area of the rectangled triangle that has base A and height C.
b) the area of the circle of radius C. (pi = 3.14159)
c) the area of the trapezium which has base A and B and C by height.
d) the area of the square that has side B.
e) the area of the rectangle that has sides A and B.
a) the area of the rectangled triangle that has base A and height C.
b) the area of the circle of radius C. (pi = 3.14159)
c) the area of the trapezium which has base A and B and C by height.
d) the area of the square that has side B.
e) the area of the rectangle that has sides A and B.
Input
The input file contains three double numbers with one digit after the decimal point.
Output
The output file contains 5 lines of data. Each line correspond to one of the areas described above, always with a corresponding message (in portuguese) and one space after the ":" and before the calculated number. All calculated number must be printed with 3 digits after the decimal point.
Sample Inputs | Sample Outputs |
3.0 4.0 5.2 | TRIANGULO: 7.800 CIRCULO: 84.949 TRAPEZIO: 18.200 QUADRADO: 16.000 RETANGULO: 12.000 |
12.7 10.4 15.2 | TRIANGULO: 96.520 CIRCULO: 725.833 TRAPEZIO: 175.560 QUADRADO: 108.160 RETANGULO: 132.080 |
Solution:
#include <stdio.h>
int
main() {
double
a,b,c;
double
pi=3.14159;
scanf
(
"%lf %lf %lf"
,&a,&b,&c);
printf
(
"TRIANGULO: %.3lf\n"
, (a*c)/2);
printf
(
"CIRCULO: %.3f\n"
, pi*c*c);
printf
(
"TRAPEZIO: %.3lf\n"
, ((a+b)*c)/2);
printf
(
"QUADRADO: %.3lf\n"
, b*b);
printf
(
"RETANGULO: %.3lf\n"
, a*b);
return
0;
}
No comments:
Post a Comment