Wednesday, December 2, 2015

Uri problem 1010 solve

Problem :

Simple Calculate

Adapted by Neilor Tonin, URI  Brazil
Timelimit: 1
In this problem the task is read a code for a product 1, the number of units of product 1, the price for one unit of product 1, the code for a product 2, the number of units of product 2, the price for one unit of product 2 and calculates and print the amount to be paid.

Input

The input file contains two lines of data. In each contains 3 numbers: two integers and a floating number with 2 digits after the decimal point.

Output

The output file will contain a message like the following example where "Valor a pagar" means Value to Pay. Remember the space after the ":" and after the "$" symbol. The value must be printed with 2 digits after the point.
Sample InputsSample Outputs
12 1 5.30
16 2 5.10
VALOR A PAGAR: R$ 15.50
13 2 15.30
161 4 5.20
VALOR A PAGAR: R$ 51.40
1 1 15.10
2 1 15.10
VALOR A PAGAR: R$ 30.20

Solution:

#include <stdio.h>
  
int main() {
  
    int code1 , unit1 , code2 , unit2 ;
    float  unitprice1  ,unitprice2 , Total;
    scanf("%d %d %f",&code1 , &unit1 ,&unitprice1 );
    scanf("%d %d %f",&code2 , &unit2 ,&unitprice2);
    Total  = (unit1*unitprice1) + (unit2*unitprice2);
    printf("VALOR A PAGAR: R$ %.2f\n",Total);
  
    return 0;
}

No comments:

Post a Comment